PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Giulietta Radio zeigt CODE ERROR nach CAN-BUS Interface Einbau



Il MiTo
20.03.2016, 14:40
Hi @ all,

hab folgendes Problem und vielleicht weis ja jmd rat.

Habe in meine Giulietta (Bj. 2010) mein Parat Asteroid Tablet installiert und hierzu war das zwischenschalten eine CAN-BUS-Adapters notwendig.

Das Tablet und die damit verbundenen Funktionen funktionieren alle tadellos im Giulietta und ich freue mich bereits auf die endgültige Verlegung im Fahrzeug.

Leider ist ein Fehler aufgetreten den ich nicht beseitigt bekomme. :cry:


Sobald ich das Can-Bus Interface in die Jule einbaue zeigt das Radio "CODE ERROR".

Somit kein Radioempfang und auch keine Lautstärkeregelung via Radio möglich.

Habe bereits versucht diverse Kabel zu vertauschen; leider ohne Erfolg.

Hat viellicht jemand eine Idee oder einen Lösungsvorschlag?


Vielen Dank im Voraus für alle Tipps und Ideen.

alfaeffect
20.03.2016, 14:51
Ohne Adapter funktioniert das Radio?
Es wäre auch von Vorteil von welchen Adapter man spricht und wie und wo er angeschlossen wurde.
Vllt mit Bildern

fabrim
20.03.2016, 14:54
Hi. Hast du eine separate Code Karte für das Original Radio? Bei neueren Modellen ist es mittlerweile so das Radios von einer Fachwerkstatt angelernt werden müssen. Das ist der Moderne Radio Code bei Neufahrzeugen. Ob deiner jetzt betroffen ist weis ich auf Anhieb nicht. Warte mal noch ob jmd anderes ne Idee hat oder mal das gleiche Problem hatte

Il MiTo
20.03.2016, 15:12
Hi alfaeffect,

ja ohne Adapter funktioniert alles wie gewohnt. Allerdings hat das Tablett dann keine Funktion.

Bilder kann ich gerne anfertigen. Adapter ist von NIQ.

Anschluss:

CAN-BUS Adapter an Orignalkabelbaum

Dann ins Steuergerät vom Parrot Tablet und dann zurück in Ori. Radio.

Eddy
20.03.2016, 16:02
Hast du mal ein Proxi durchlaufen lassen ?

Il MiTo
20.03.2016, 16:04
Hi Eddy, wie meinst du Proxy?


Gesendet von iPhone mit Tapatalk

Eddy
20.03.2016, 16:39
Mit MES oder AlfaOBD wird bei CAN Bus Fehlern ein Proxi Aligment gemacht
mit dem Verfahren werden die Schnittstellen im CAN Bus alle neu gesucht und angemeldet.

Es kommt hin und wieder vor das Steuergeräte nicht erkannt werden oder Fehler anzeigen
dies wird durch blinkenden Tachostand angezeigt

Dann hilft es mit MES oder AlfOBD ein solches Verfahren durch zu führen damit die fehlende /fehlerhafte Steuerung gefunden wird.

Und da du ja im Prinzip mit deinem CAN Interface eine neue Steuerung hin zu gefügt hast
könnte ein neues Anlernen helfen

Il MiTo
20.03.2016, 16:54
Ok vielen Dank für den Tipp. Muss mich mal mit beschäftigen, da ich bisher diese Tools noch nicht genutzt habe.

alfaeffect
20.03.2016, 17:01
Proxy Ausrichtung brauch er nicht machen.
Er greift nur ab und pflegt nicht ein. ;)

Hast Du die richtigen Leitungen genommen, ist der Adapter einstellbar?

Il MiTo
20.03.2016, 17:16
Leitung konnte ich keine Auswählen weil Plug n Play. Einstellen am Interface kann ich leider nichts. Die Prüf LED leuchtet aber Grün und ist gemäß Anleitung in Ordnung.


Gesendet von iPhone mit Tapatalk

guzzi97
22.03.2016, 00:45
Moinsen,
der CAN-BUS Adapter ist nicht in Ordnung, entweder, Du hast den falchen bekommen, oder
aber, er ist defekt.
Umtauschen das Teil und gut isss :)

Il MiTo
24.03.2016, 07:32
Moinsen,
der CAN-BUS Adapter ist nicht in Ordnung, entweder, Du hast den falchen bekommen, oder
aber, er ist defekt.
Umtauschen das Teil und gut isss :)

Moin,

deine Vermutung hat sich leider nicht bestätigt.
Habe probeweise ein anderen Adapter verbaut und leider verschwindet der Fehler nicht.
Sobald ich alles auf Original umrüste ist das Radio wieder normal da.

Irgendwie scheinen die Adapter das CAN BUS vom Original-Radio zu blockieren bzw. geben das Signal nicht weiter.:??

Bin jetzt am überlegen ob das löttechnisch nicht irgendwie überbrücken kann.

Hab zwar ein super Multimedia-/Freisprechsystem im Auto kann aber das Ori-Radio inkl. Laustärkeregler nicht nutzen.:cry:

alfaeffect
24.03.2016, 10:59
Was genau soll der Adapter denn machen? Bzw für was wird er gebraucht?

Il MiTo
24.03.2016, 11:00
Soll eigentlich nur Dauer plus abgreifen und weiterleiten


Gesendet von iPhone mit Tapatalk

guzzi97
24.03.2016, 11:01
Hi,
mal "blöd" gefragt, Du hsat doch Quadlock und keine ISO (zwei Reihen a 8 Pins) ?

Wen Quadlock ( http://s013.radikal.ru/i323/1411/8c/58d00d6ef1ef.jpg ) dann benötigst Du auf jedenfall noch
einen Adapter Quadlock auf ISO
Wenn ISO, dann ist "Can A" auf Pin 1 und "Can B" auf Pin 3 (https://www.alfa-romeo-portal.de/arcommunity/mitglieder-alben/guzzi97/album/guzzi-s-car-hifi-umbau/550-0-schaltplan-serien-hu-mit-mp3.jpg )

Btw. den Schaltplan findest Du normalerweise auf dem orig.Radio, i.d.r.

Anderseits, Du bist der erste der ein Problem mit einem "Nachrüchstradio" hat, daher stelle ich mal die Vermutung ab,
dass was mit dem Tablet nicht o.k. ist.

alfaeffect
24.03.2016, 11:26
So wie ich das verstehe bleibt das Original Radio.
Die Parrot FSE soll dazwischen.

Ich mach ein Bild wie Du es angeschlossen hast.
Ich vermute mal Du hast ein Denkfehler drin.

Nachtrag:
Wir schauen mal genau in die BA auf Seite 13 Installation und schauen uns dort nur das Bildchen an ohne lesen.
83879
Und was stellen wir fest? Die FSE erwartet normales Plus und Minus und schickt es dementsprechenden auch wieder raus.
Somit ist Dein Adapter dafür schon mal nicht mehr zuständig, weil er das schlicht weg nicht so umsetzt wie das Radio es erwartet.
Du musst nur schauen wo Du die Stummschaltung, Handbremse und Tonsignal durch die FSE durchschleifst.
Die Can Bus Adapter sind dafür gedacht wenn man das OEM Radio gegen ein Nachrüstradio tauscht.
Und das ist nicht der Fall.
Man kann in den Adapter nur das Bus Signal reinschicken aber nicht wieder herausholen oder durch schleifen.
Wenn Du die umgewandelten Signal haben möchtest, dann musst Du Dir das so bauen das die Originalen Signale wieder herauskommen, sonst versteht Dein Radio nur Bahnhof und geht im besten Fall kaputt und im schlimmst Fall brennt der ganze Alfa ab. Die mittlere Alternative wäre noch Zerstörung andere Steuerteile, der CAN Bus ein 2 Leitungssystem ist.
Und das ist keine Panikmache sondern wirklich so.

Il MiTo
24.03.2016, 12:47
Hallo nochmal,

zunächst mal möchte ich mich sehr für das entgegengebrachet Engagement und die Hilfestellung bedanken. Echt ein TOP-FORUM!:-->>

Wenn ich das nun richtig verstehe ist somit der CAN BUS Adapter an dieser Stelle nicht geeignet bzw. überflüssig und muss wieder raus um evtl. folgeschäden zu vermeiden.

Nun stellt sich mir die Frage wie ich das Parrot-System zum laufen bekomme? Wo kann ich das Züdungsplus abgreifen um das Tablet funktionsfähig zu machen? Gibt es da anderweitige Adapter?

alfaeffect
24.03.2016, 13:17
Da ich mich mit der Belegung des OEM Radios nicht 100% auskennen müsste man sich erst mal schlau machen wie Du die Mute Funktion und den Ton in das Radio reinbekommst.
Und damit meine ich das Du mal googel quälen musst.
Bilder von der Rückseite vom Radio wären hier auch wieder von Vorteil.
Sind die erwähnten Aufkleber von guzzi auf dem Radio?
Plus und Minus ist Dein geringstes Problem. Mitarbeit ist das A und O.
Wenn es keine Adapter dafür gibt kann man sich was dem jetzigen Adapter selber bauen. Now How und Werkzeug natürlich als Voraussetzung.

Il MiTo
24.03.2016, 13:39
Genau dieser von guzzi aufzeigte Aufkleber ist auf meinem Radio auch vorhanden.(https://www.alfa-romeo-portal.de/arc...hu-mit-mp3.jpg (https://www.alfa-romeo-portal.de/arcommunity/mitglieder-alben/guzzi97/album/guzzi-s-car-hifi-umbau/550-0-schaltplan-serien-hu-mit-mp3.jpg) ).

Fotos von der ganzen Situation werde ich heute Nachmittag anfertigen können.

alfaeffect
24.03.2016, 14:41
Na dann ist die Sache ganz einfach.
Mute an Mute, Masse vom Iso Stecker, LS Paare durchschleifen, Dauer sowie geschaltetes Plus anschließen und die Handbremse nicht vergessen fertig.

guzzi97
24.03.2016, 15:10
..Zündungsplus bekommste vom Zig.-Anzünder, od. ausm Sicherungskasten..
Den Rest, so wie Alfaeffect schreibt ;)