PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Fehlerspeicher selbst auslesen und löschen?



ltz400
24.05.2015, 21:54
Hallo liebe Kollegen,

jetzt hab ich doch gleich noch die nächste Frage:

Was brauche ich um bei meiner Diva den Fehlerspeicher selbst auslesen und bei Bedarf auch löschen zu können?

Ich hab heute jetzt zum zweiten Mal ein leuchtendes Motorwarnsymbol in der Instrumentenanzeige. Beim ersten Mal hab ich den Fehler in der Werkstatt auslesen und löschen lassen. Der/die Fehler lauteten P1177 und P1178 Multiplikative Gemischadaption Zyl. 1+4 und 2+3 (Teillast), Gemisch zu fett/mager.

Ich gehe mal davon aus, dass der Fehler jetzt wieder der gleiche ist und ich denke, ich kenne auch die Ursache. Nach dem Kaltstar hört man für ein bis zwei Minuten dass der Motor irgendwo im Bereich des Krümmers abbläst, später hört man nichts mehr, aber durch die vorhandene Undichtigkeit zieht der Auspuff wohl vor den Lambdasonden Falschluft und läuft daher zu fett (Auspuff Endrohr ist auch schon ganz schön schwarz innen).

Die entsprechende Reparatur steht momentan aber nicht ganz oben auf meiner ToDo-Liste und nachdem das Auslesen und löschen jedesmal Euro 30,-- kostet bin ich auf der Suche nach einer günstigen und funktionierenden Lösung um das auch selbst machen zu können. Kann man später ja auch noch für andere Analysen nutzen.

Ich freue mich auf eure Empfehlungen!

Grüße
Alex

Eddy
24.05.2015, 21:59
Hi Alex

Welches Bj. ist dein Spider ?

ltz400
24.05.2015, 22:01
Hallo Eddy,

Bj 2001 2.0TS 150PS

Eddy
24.05.2015, 22:10
Hallo Eddy,

Bj 2001 2.0TS 150PS


Mit diesem KKL Interface (http://www.ebay.de/itm/161604649426?_trksid=p2055119.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT) kannst du auf alle Steuerungen zugreifen die

AlfaOBD (http://www.alfaobd.com)

oder

Multiecuscan (http://www.multiecuscan.net)

erlauben

Falls du aber per Smartphone (Android) auslesen möchtest

Geht dies nur mit AlfaOBD Androit (http://alfaobd.com/download.html)

Aber dann benötigst du ein anderes Interface welches allein schon min. 130 € kostet

Ein OBDkey (http://www.obdkey.com/obd_bluetooth_info.asp)

Und die verschiedenen Adapterkabel (http://www.ebay.de/itm/161604565671?_trksid=p2060353.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT)

ltz400
24.05.2015, 22:19
Hallo Eddy,

ich blick das noch nicht so ganz.

Hat meine Diva bereits eine OBDII Schnittstelle?

Mit dem günstigen Adapter auf USB brauch ich dann noch welche Software auf dem (Windows-)Schleppi?

Gibt es alternativ nicht ne kleine autarge Komplettlösung mit nem LCD-Display?

Gruß
Alex

Eddy
24.05.2015, 22:37
Sorry Alex

Da ich heute und per PN auch schon 916er hatte
habe ich ganz vergessen

Welche Bj hat dein 916er ?

Beiträge au***atisch zusammengeführt

Zum Auslesen mit LCD Display wird es schwierig.

Da ich mal Annehme wenn möchtest du auch die möglichkeit haben

ABS , Airbag , Klima , usw auszulesen

Und da gibt es kaum kostengünstiges für die italienischen Au***obile
aber auch für andere wird es dann teuer

ltz400
24.05.2015, 22:40
Hallo Eddy,

Bj. 2001

Hab mich inzwischen schon ein wenig eingelesen.
Soweit ich verstanden habe, kann ich das KKL-Interface mit der kostenlosen Multiecuscan Software nutzen, oder für Euro 50,-- eine Lizensierte Vollversion der Software kaufen.

Reicht für meine Zwecke die kostenlose Version?

Gruß
Alex

Eddy
24.05.2015, 23:06
Ja rein zum Auslesen reicht für dich die kostenlose Version

Da du wenn ich richtig sehe die M1.5.5 oder die M7.3.1 hast die gehen ganz gut mit der kostenlosen

Obwohl ich die kostenlose Verson von AlfaOBD mehr Vorteile hat als die kostenlose Version von MES


Mit usb reicht dir das schaltbare KKL vollkommen aus

ltz400
24.05.2015, 23:09
Und die kostenlose Version von AlfaOBD funzt auch mit dem KKL?

Eddy
24.05.2015, 23:13
Ja

ltz400
24.05.2015, 23:31
Super!

Hast du auch noch nen Link zum Download?

Oder soll ich mir gleich das Paket hier holen?:

Diagnose-Set ALFAOBD "KKL INTERFACE 3-DIP" -mit DIP-Schalter-inkl.1x Lizenz- KKL DIAGNOSE! - Electronic-Fuchs (http://electronic-fuchs.de/epages/e87b02f8-46da-4792-be6d-42392d89d882.sf/de_DE/?ObjectPath=/Shops/e87b02f8-46da-4792-be6d-42392d89d882/Products/1000-34A)

PS: wie kann ich hier einen Link mit Namen verwenden?

Eddy
24.05.2015, 23:35
Da Paket von Elektronik Fuchs kannst du auch kaufen
kostet halt nur ein wenig mehr

Hast allerdings auch jemanden an den man sich wenden kann.

Von AlfaOBD hatte ich dir ja den Link gesendet

und das Interface auch

50 + 17 = 67 €

ltz400
24.05.2015, 23:48
OK,

also nur nochmal zur Sicherheit.

ich kaufe das (ist noch ein paar Euro günstiger):

AutoDia K410 für Fiat Alfa Romeo Lancia Interface KL OBD 2 Diagnose Scanner OBD2 | eBay (http://www.ebay.de/itm/AutoDia-K410-fur-Fiat-Alfa-Romeo-Lancia-Interface-KL-OBD-2-Diagnose-Scanner-OBD2-/151635713099?pt=LH_DefaultDomain_77&hash=item234e315c4b)

Und dazu noch das:

http://www.amazon.de/AlfaOBD-com-AlfaOBD/dp/B00S715LCQ/ref=sr_1_2?ie=UTF8&qid=1432503760&sr=8-2&keywords=alfaobd

und hab dann für 14,95 + 40,23 = 55,18 alles zusammen was ich brauche?

Gruß
Alex

ltz400
24.05.2015, 23:53
UPS! Ich glaub mit der Software im Link hab ich mich vertan! Die ist nicht für PC sondern nur für Android!

Eddy
25.05.2015, 00:05
UPS! Ich glaub mit der Software im Link hab ich mich vertan! Die ist nicht für PC sondern nur für Android!

Richtig , wollte ich dich gerade darauf aufmerksam machen

Aber wenn du ein Tablet (Android) mit usb hast geht auch die Androit Version

ltz400
25.05.2015, 00:17
Mein Tablet hat IOS, aber ich hab noch ein älteres Samsung Smartphone hier.
Ginge das auch, oder braucht man zur Bedienung ein größeres Display?

Wäre ja grundsätzlich schon praktischer als immer den Schleppi zum Auto zu karren.

Eddy
25.05.2015, 00:33
Nur für das Smartphone benötigst du ein BT oder Wlan Interface
nur die meisten sind nur auf ELM Basis zu erhalten

Daher könntest du mit dem Samsung dann nur auf dein Motorsteuergerät zugreifen

Oder halt das oben genannte OBDkey das kann auch die KKL Protokolle lesen
kostet aber einiges mehr

ltz400
25.05.2015, 00:38
Na dann doch lieber Schleppi!

Gallitz
27.05.2015, 17:32
Sorry für Off Topic:

@Eddy weißt Du auch einen Diagnose Stecker für meinen Alfa 916 GTV Bj. 95 2.0 V6 TB? Und welches Programm man damit dann verbinden kann?

SelespeedDriver
27.05.2015, 17:35
Programme sind die gleichen, aber ich meine, dass du ein anderes Interface brauchst? *grübel* oder war es nur ein Adapter? *nochmehrgrübel*
Der Eddy weiß das aber bestimmt genau ;)

Eddy
28.05.2015, 07:07
Klar doch Sara
Für´s Laptop
Mit AlfaOBD (http://www.alfaobd.com)oder Multiecusan (http://www.mutliecuscan.net) verwendbar
+
KKL Interface (http://www.ebay.de/itm/151635709562?_trksid=p2055119.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT)
+
3pin Adapter (http://www.ebay.de/itm/161617861705?_trksid=p2055119.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT)


Oder mit dem Smartphone (Android)
da wird es aber etwas teurer

OBDkey Interface (http://www.obdkey.com/obd_bluetooth_info.asp)
+
3pin Adapter (http://www.ebay.de/itm/161617861705?_trksid=p2055119.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT)
+
AlfaOBD Android (http://alfaobd.com/download.html)

Gallitz
28.05.2015, 15:50
Tausend Dank Dir Eddy!
LG

ltz400
28.05.2015, 23:16
Hallo Eddy,

kannst du mir nochmal weiterhelfen?

Heute ist das Interface bei mir eingetroffen und nachdem ich die Treiber installiert habe, hab ich auch gleich die AlfaOBD-Software (bisher ohne Lizensschlüssel) auf meinen Schleppi gespielt.

Welches Interface muss ich denn bei der Software als Schnittstelle eintragen?
Das AutoDia K410 steht ja nicht zur Auswahl.

Gruß
Alex

Eddy
28.05.2015, 23:35
Das KKL auswählen

73400

ltz400
28.05.2015, 23:51
Super! Vielen Dank!

Muss ich an der virtuellen Com-Schnittstelle vom Rechner auch noch was einstellen, oder passen da die Grundeinstellungen (Baud 9600, Datenbits 8 etc.)?

Eddy
28.05.2015, 23:55
einfach lassen , an den Werten habe ich noch nie herum getüfftelt.

Gallitz
28.05.2015, 23:58
Kann man mit dem Programm eigentlich auch am Kennfeld rumtüfteln (also reprogrammieren)?

Eddy
29.05.2015, 00:03
Kann man mit dem Programm eigentlich auch am Kennfeld rumtüfteln (also reprogrammieren)?

Nein , das ist eine andere Hausnummer


Dazu benötigst du ein anderes Interface (Galletto oder MPPS) zum Download des Kennfeldes
Dann ein weiteres Programm um das Kennfeld zu ändern.
Wenn man weiß was wo zu tun ist. :wink:
Und dann kann das Kennfeld wieder aufgespielt werden.

Mit AlfaOBD oder MES ist da nichts möglich :-D

Gallitz
29.05.2015, 00:06
Achso. Hätte ja sein können. Dann muss ich Dich diesbezüglich auch mal anschreiben. Aber erstmal vielen Dank für Deine kompetente Antwort, Eddy! :knutsch:

ltz400
30.05.2015, 23:02
Hallo Eddy,

ich brauch nochmal deine Hilfe!

Ich hab jetzt versucht das Steuergerät auszulesen, aber ohne Erfolg.
Die Software versucht ständig die Verbindungsparameter heraus zu finden (oder sowas in der Richtung), aber ohne Erfolg.

Ich hab die AlfaOBD-Software jetzt auf eine Win-XP-Netbook am laufen. USB-Com Treiber hab die installiert die bei dem AutoDia K410 Interface-Kabel auf CD dabei waren.

Sobald ich das Interface-Kabel auf die Schnittstelle im Auto anstecke leuchtet die rote LED permanent, egal in welcher Stellung der Zündschlüssel steht.

Muss ich die anderen Parameter im AlfaOBD auch so einstellen wie bei deinem Screenshot, also die diversen Wartezeit Werte ändern und diese Code Karten Nummer eingeben?

Ich sollte übrigens ein Bosch ME 7.3.1 Steuergerät haben und das hab ich auch so in der Software eingestellt.

Was mach ich noch falsch?!?

Gruß
Alex

Eddy
30.05.2015, 23:35
Hi Alex

Den Treiber auf der CD sollte man nicht nehmen die sind oft Fehlerhaft
und machen Probleme

Daher hatte ich mal eine Anleitung erstellt, die ist zwar für MES kann aber für AlfaOBD übernommen werden.

Installationsanleitung (http://www.alfa-romeo-portal.de/arcommunity/bereich/reparaturanleitungen-alfa-romeo/neue-installationsanleitung-f%FCr-interfacce-fes-2-7-709.html)

Nimm aber den 2.10.0 Treiber



Die Werte brauchst du nicht nach meinem Screenshoot übernehmen
die stellen sich selbstständig ein.
Sollten das jedenfalls , ich habe noch niemals die Parameter geändert.


Das die rote LED leuchtet ist normal schließlich bekommt dein Interface von der Batterie dauerhaft 12 Volt

ltz400
31.05.2015, 01:06
Hallo Eddy,

hat leider nix gebracht. Ich hab die neusten XP-Treiber von der angegebenen Seite installiert und die Wartezeit vom Com-Port auf 1 runtergesetzt, wie in deiner Anleitung angegeben, aber leider ohne Erfolg. Ich krieg keine Verbindung!

Morgen, also heute probier ichs dann nochmal mit meinem anderen Win7 Schleppi. Vielleicht funktionierts mit dem?

Gruß
Alex

Eddy
31.05.2015, 08:59
Hi Alex

Dann weiß ich auch nicht mehr weiter

Vielleicht solltest du dir jemanden in deiner Nähe suchen der
Auslesen kann

Liste von Kabel und Software Inhabern (http://www.alfa-romeo-portal.de/arcommunity/private-schrauber-ecke-122/liste-von-diagnosekabel-und-software-inhaber-19080.html)

um dann den Fehler zu finden.

ltz400
31.05.2015, 17:06
Also,

der Test mit dem Win7 Rechner hat auch nichts gebracht. Deshalb hab ich mir auf beiden Rechnern nochmal zusätzlich zum AlfaOBD das Multiecuscan installiert und mit dem probiert. Bei dem kann man zumindest eine Interfacetest ausführen der auch auf beiden Rechnern erfogreich durchlief, nur das Verbinden zur Steuereinheit funktionierte eben nicht.

Als ich schon aufgeben wollte, hatte ich dann aber doch noch Erfolg!
Ich hatte, laut Anleitung, bei allen Tests den Zündschlüssel immer in der "MAR"-Stellung stehen. Das ist bei meiner Diva aber falsch! Erst bei Zündung an krieg ich Verbindung mit dem Steuergerät und zwar mit beiderlei Software!

Hat jetzt jedenfalls funktioniert und der ausgelesene Fehler war so wie erwartet und wurde deshalb auch wieder gelöscht.

Gruß
Alex

Eddy
31.05.2015, 18:23
??????

Ja klar :shock: das Steuergerät muss mit Strom versorgt werden um Daten heraus zu geben ???

Beiträge au***atisch zusammengeführt

Du hast mich jetzt so verunsichert :shock: , das ich noch mal nachschauen musste :wink:

In meinen Anleitungen steht immer zündung ein und Verbinden drücken

ltz400
31.05.2015, 22:06
Ja Eddy da hast du recht, aber in der Software selbst wird immer nur diese "MAR"-Stellung der Zündung genannt und ich dachte, die wäre identisch mit "Zündung ein", aber das scheint nicht bei allen Fahrzeugen so zu sein.

Hätte ich mich genauer nach deiner Anleitung richten sollen:thumb:

Danke und Grüße

Alex

fabrim
31.05.2015, 22:16
An die Anleitungen die hier zur Verfügung stehen ist es immer ein MÜSST sich an das zu halten was da steht [emoji16]

Eddy
31.05.2015, 23:15
Ja Eddy da hast du recht, aber in der Software selbst wird immer nur diese "MAR"-Stellung der Zündung genannt und ich dachte, die wäre identisch mit "Zündung ein", aber das scheint nicht bei allen Fahrzeugen so zu sein.

Hätte ich mich genauer nach deiner Anleitung richten sollen:thumb:

Danke und Grüße

Alex


Na wenigsten hat es nach diesen vielen Beiträgen zu einem Erfolg geführt.

Übrigens MAR ist Zündung ein auch an meinem 156 :roll:

ltz400
31.05.2015, 23:27
Übrigens MAR ist Zündung ein auch an meinem 156 :roll:

Bei meinem nicht, ich muss den Schlüssel noch eine Raste weiter im Zündschloss drehen, bis die ganzen Instrumentenanzeigen und die Lüftung (falls angeschaltet) angehen. Erst dann krieg ich Verbindung zum Steuergerät:letsrock: