PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Rote Airbaglampe leuchtet, aber kein Fehler im Speicher!?



Corben
10.03.2014, 21:26
Hallo Leute :winkewinke:,

analogwarrior war so hilfsbereit, unter Verwendung des ELM 327 Bluetooth Interace (moddet by Eddy) den Fehlerspeicher meines 147 (Baujahr 2001) auszulesen, da bei dem seit einigen Monaten die rote Airbagkontrolllampe leuchtet.

Zuerst haben wir es mit der Vollversion von Fiatecuscan probiert, aber damit kam keine richtige Verbindung zustande, auch nicht zu seinem 147.
Mit Multiecuscan (Version?) ging es dann, aber *trommelwirbel* => es steht kein Fehler im Speicher!?! :cry:

Hat jemand eine Idee, wieso die Lampe dennoch leuchtet?

Allerdings frage ich mich, wie man zwischen dem Airbagsteuer- und Motorsteuergerät unterscheiden soll, wenn es anscheinend(?) nur eine Anzeigefläche dafür gibt.:??

Eddy
11.03.2014, 06:32
Ich frage mich gerade wie Ihr mit dem ELM eine Verbindung zum Airbagsteuergerät herstellen konntet. ??
Dazu benötigt man für den 147 ein KKL Interface umschaltbar oder mit roten Adapter


Allerdings frage ich mich, wie man zwischen dem Airbagsteuer- und Motorsteuergerät unterscheiden soll, wenn es anscheinend(?) nur eine Anzeigefläche dafür gibt.:??

Dem ist nicht so , denn man wählt entweder die Motorsteuerung oder die Airbagsteuerung aus.
Und hat somit unterschiedliche Anzeigeflächen

Also mit dem ELM geht das nicht , dies war wohl euer Fehler ?

Gruß Eddy

guzzi97
11.03.2014, 07:41
..korrekt, das ELM funzt nur bei den "neuen" Modellen, beim 156er/147er kommt mann nur
mit einem KKL auch auf die anderen Stg., leider..
Daher, kein Wunder, dass ihr keine Meldung gefunden habt, ihr wart auf dem "falschen" Stg.

Grüße

Corben
11.03.2014, 20:37
Ich danke Euch. Das lässt mich zumindest wieder hoffen, denn es wäre mir deutlich lieber, daß es was mit einem der Stecker zu tun hätte oder im schlimmsten Fall ein klar eingrenzter Betrag für die Reparatur des Airbagsteuergeräts auf mich zukäme, als daß es ein diffuser Fehler wäre, der von der normalen Werkstatt entweder gar nicht oder nach viel zu vielen unnötigen Stunden gefunden würde.

Was ich nicht verstehe:
Wieso steht der Airbagfehler nicht auch im Motorsteuergerät? Wenn das Airbagsteuergerät einen "Totalschaden" hätte oder fehlen würde, müsste die Lampe ja auch leuchten (bzw. der Fehler detektiert / angezeigt werden) und wie sollte das gehen, wenn sie das nur tut, wenn der Fehler ausschließlich im gar nicht funktionierenden/vorhandenen Airbagsteuergerät stünde? http://www.alfa-romeo-portal.de/arcommunity/images/smilies/smilie_denk2.gif


und warum analogwarrior ein Interface hat (und zudem extra ein gemoddetes), mit dem man bei nicht in's Airbagsteuergerät kommen soll, verstehe ich außerdem nicht, denn er hat ja auch einen 147. :??




BTW: wie gehen die Stecker eigentlich auf? Muss man die Klammern am schmalen Ende zurückdrücken, damit man diese Seite rausziehen kann?

Eddy
11.03.2014, 22:37
Wieso steht der Airbagfehler nicht auch im Motorsteuergerät? Wenn das Airbagsteuergerät einen "Totalschaden" hätte oder fehlen würde, müsste die Lampe ja auch leuchten

Da es sich um zwei verschieden Steuergeräte handelt die keine Verbindung untereinander haben.
Und auch beim 147 wie bei allen sontigen Fahrzeugen auch, ist die Motorkontrollleuchte und die Airbagkontrolleuchte nicht die gleiche
Die Kontrolleuchte (Airbag) leuchtet auch wenn das Steuergerät fehlen würde. Dies hat etwas mit der Beschaltung der Kontrollleuchte zu tun
und nicht direkt ob ein Steuergerät vorhanden ist oder nicht.




und warum analogwarrior ein Interface hat (und zudem extra ein gemoddetes), mit dem man bei nicht in's Airbagsteuergerät kommen soll, verstehe ich außerdem nicht, denn er hat ja auch einen 147. :??


Er hat ein "gemoddetes" ELM um damit
- CAN Bus Protokolle lesen zu können.
- damit er keine Adpaterkabel zum auslesen der verschiedenen Steuerungen zu benötigen.

Da aber beim 147 das Airbag noch über ein älteres Protokoll gelesen wird. Welches das ELM nicht
verarbeiten kann. Wird ein anderes Interface benötigt welches dies Protokoll kennt.

Gruß Eddy

analogwarrior
12.03.2014, 20:08
Also mit dem ELM geht das nicht , dies war wohl euer Fehler ?


jo, dann ist das unser Fehler gewesen :wink:

@Corben: blöd, dann kann ich Dir leider auch nicht weiter helfen.

guzzi97
13.03.2014, 10:44
....wie Eddy sagte..

das "VAG-KKL" ist für Modelle vor CAN-BUS, also alle 156/147/166, 145/146/155/164, Boxer, etc.
das "ELM" für Modelle mit CAN-BUS, ala 159/Brera/Spider/Mito/Julchen/4C/8C, etc...

Einzige Gemeinsamkeit, mit dem KKL und ELM kann mann, bis auf die "ganz alten Fzg."
gegenseitig auf die ECU zugreifen.

Bei den anderen Hersteller verhält es sich gleich.

Hoffe ist ein bissel klarer
Grüßle

analogwarrior
13.03.2014, 19:22
jo, jetzt ja ... man lernt halt nie aus :mrgreen:

hatte ja bisher (zum Glück) noch keinen Airbag Fehler, sonst hätte ich's wohl schon raus gefunden.

Corben
13.03.2014, 21:43
Und auch beim 147 wie bei allen sontigen Fahrzeugen auch, ist die Motorkontrollleuchte und die Airbagkontrolleuchte nicht die gleiche


Das ist klar, aber ich dachte, der Airbagfehler müsste auch im Motorsteuergerät stehen.





Die Kontrolleuchte (Airbag) leuchtet auch wenn das Steuergerät fehlen würde. Dies hat etwas mit der Beschaltung der Kontrollleuchte zu tun und nicht direkt ob ein Steuergerät vorhanden ist oder nicht.

Was ist denn, wenn sich das Airbagsteuergerät komplett verabschiedet, bleibt dann die Lampe aus, weil es ja noch eingebaut ist? :D Oder ist das so unwahrscheinlich, daß sowas quasi nie passiert?



Er hat ein "gemoddetes" ELM um damit
- CAN Bus Protokolle lesen zu können.
- damit er keine Adpaterkabel zum auslesen der verschiedenen Steuerungen zu benötigen.

Da aber beim 147 das Airbag noch über ein älteres Protokoll gelesen wird. Welches das ELM nicht
verarbeiten kann. Wird ein anderes Interface benötigt welches dies Protokoll kennt.

Gruß Eddy

Ok, danke für die Erklärung.




jo, dann ist das unser Fehler gewesen :wink:

@Corben: blöd, dann kann ich Dir leider auch nicht weiter helfen.

schon gut, immerhin habe ich keinen Fehler im Motorsteuergerät :D





Hoffe ist ein bissel klarer


ja, etwas :D Danke

Eddy
13.03.2014, 22:00
Das ist klar, aber ich dachte, der Airbagfehler müsste auch im Motorsteuergerät stehen.

Nein , und ich denke mal das möchte auch kein Autohersteller so haben , damit nicht ein Fehler einen anderen simuliert


Was ist denn, wenn sich das Airbagsteuergerät komplett verabschiedet, bleibt dann die Lampe aus, weil es ja noch eingebaut ist? :grin: Oder ist das so unwahrscheinlich, daß sowas quasi nie passiert?

Wenn es sich komplett verabschiedet, passiert das gleiche als wenn es ausgebaut wäre
die Leuchte würde brennen.

Wie soll ich das erklären ?

Vielleicht ähnlich wie bei der Lichtmaschine , da brennt die Ladelampe auch wenn der Motor nicht läuft
da die Lampe Masse über die Spule der Lichtmaschine erhält und brennt.
lädt die Lichtmaschine bekommt die Leuchte von beiden Anschlüssen her 12 - 14 Volt + und leuchtet nicht.

Ähnlich ist es bei der Airbagleuchte nur das dort über einen Transistor der Stromfluss gesperrt wird und die
Leuchte aus geht. Und liegt das Signal nicht an leuchtet die Kontrollleuchte.


Gruß Eddy

Corben
14.03.2014, 06:06
ok, danke Eddy


Hätte vielleicht jemand noch eine(n) Anleitung/Hinweis, wie man die gelben Airbagstecker ausgesteckt bekommt?
Schnürt man den Kabelbinder um die schmale Seite?

Eddy
14.03.2014, 06:39
Nein man macht die Sicherung so das beide Gehäusehälften zusammengehalten werden
und nicht auseinander gehen können .
Dann sollte das Steckergehäuse so positioniert werden damit der nicht wild herumfallen kann.

guzzi97
14.03.2014, 08:07
..und bevor mann sich an die Stecker ran macht, bitte die Batt. für min. 20 min abklemmen..
sonst kann es zu weiteren F-Meldungen kommen oder gar das der Airbag auslöst.
Also, bitte mit Obacht daran arbeiten !

Corben
08.07.2014, 06:50
Hallo Leute, ich hab jetzt noch mal eine Frage zur Sicherheit.

Kommt man mit diesem Interface (http://www.ebay.de/itm/Interface-AutoDia-fur-Fiat-Alfa-Romeo-Lancia-OBD-2-Diagnose-Scanner-OBD2-Tester-/151015653820?pt=Elektroger%C3%A4te&hash=item23293c01bc) (auch) auf das Airbag-Steuergerät (sowie das Motor-Steuergerät) bei meinem 147 (MY2001), ohne irgendwas umzubauen? (Es steht zwar dort, daß es durch den Umschalter funktionieren soll, aber ich lasse mir das lieber von Euch bestätigen. ) :)


Oder was ist mit dem hier (http://www.ebay.de/itm/KKL-K-Line-Diagnose-Interface-OBD2-OBD1-Alfa-Romeo-Fiat-Lancia-Suzuki-SX4-/291005733872?pt=Elektroger%C3%A4te&hash=item43c14b1bf0)?




..und bevor mann sich an die Stecker ran macht, bitte die Batt. für min. 20 min abklemmen..
sonst kann es zu weiteren F-Meldungen kommen oder gar das der Airbag auslöst.
Also, bitte mit Obacht daran arbeiten !

Danke für den Hinweis, auch wenn mir (zumindest) das vorher bekannt war.

guzzi97
08.07.2014, 10:32
Hi,
das erste ist genau das richtige :) damit klappt es dann auch mit dem auslesen.
Btw. bisher war es sogar so, dass mann selbst mit der DEMO-Version und dem passenden
umschaltbaren KKL auf das Airbag-Stg. drauf kam und den Fehler löschen konnte.

Grüße

Corben
09.07.2014, 08:29
Hi,
das erste ist genau das richtige :) damit klappt es dann auch mit dem auslesen.
Btw. bisher war es sogar so, dass mann selbst mit der DEMO-Version und dem passenden
umschaltbaren KKL auf das Airbag-Stg. drauf kam und den Fehler löschen konnte.

Danke :) ,
dann schauen wir jetzt mal, was die "Kleine" hat.

Corben
18.07.2014, 21:14
Update:
Ich war vorhin bei analogwarrior und mit dem obigen Interface ist es gelungen, den Fehler auszulesen (Massefehler Beifahrerairbag) und zu löschen.
Bis jetzt ist der auch noch nicht wiedergekommen.
Schauen wir mal, ob das so bleibt. *daumendrück*

und schon hat sich das Interface amortisiert. Wann geht das schon mal so schnell? :D


Vielen Dank Euch allen (insbes. analogwarrior :) )

guzzi97
19.07.2014, 11:46
Sers,
siehste, kleine Ursache große Wirkung..
Haste den Stecker unter dem Sitz "fest gezurrt", denn spätestens beim nächsten Sitz
verstellen, könnte der Fehler wieder kommen.

Grüße

Corben
22.07.2014, 19:30
Haste den Stecker unter dem Sitz "fest gezurrt", denn spätestens beim nächsten Sitz verstellen, könnte der Fehler wieder kommen. Nein, noch nicht. Ich wollte erst mal abwarten, ob das nicht doch nur eine einmalige Geschichte war. Da ich seit heute wieder eine neue HU-Plakette hab, ist es eh erst wieder in 2 Jahren interessant, ob die Kontrollleuchte leuchtet oder nicht. :D Vielleicht mache ich das aber demnächst wirklich mal.